Jump to content

Bugs and suggestions

Sign in to follow this  

 

If you have discovered a bug or encountered an issue in any version of the Spells of Genesis gameplay, please report it here.

Please don't forget to mention these details:

  • Game version number (e.g. 1.0.0)
  • Channel (iOS App Store Channel 4 (with in-app purchases)/Android Play Store Channel 4 (with in-app purchases)/WebGL (web browser)/iOS TestFlight (without in-app purchases)/Android .apk file (without in-app purchases)
  • Device/browser and Operating System (e.g. iPhone 6 & iOS 10.1.1/Windows 10 & Chrome 54.0.2840.99 m/Samsung S7 Edge & Android OS, v6.0)
  • Describe the bug as precisely as possible, adding screenshots would be very helpful

Thank you for your help

359 topics in this forum

  1. Tutorial First VVave Failed

    • 1 reply
    • 189 views
    • 14 replies
    • 803 views
    • 1 reply
    • 187 views
    • 15 replies
    • 918 views
    • 6 replies
    • 257 views
    • 11 replies
    • 506 views
    • 3 replies
    • 188 views
    • 4 replies
    • 229 views
    • 0 replies
    • 185 views
  2. cards gone

    • 3 replies
    • 197 views
    • 1 reply
    • 194 views
  3. Gameplay bug

    • 3 replies
    • 310 views
  4. Losting diamonds in a card store

    • 2 replies
    • 249 views
    • 10 replies
    • 484 views
    • 6 replies
    • 388 views
    • 3 replies
    • 287 views
  5. Battle backgrounds

    • 7 replies
    • 398 views
    • 5 replies
    • 307 views
    • 1 reply
    • 283 views
    • 8 replies
    • 555 views
    • 1 reply
    • 227 views
    • 4 replies
    • 273 views
  6. Speed not showing cards

    • 2 replies
    • 233 views
    • 2 replies
    • 225 views
    • 1 reply
    • 211 views
Sign in to follow this  
×