Jump to content
Sign in to follow this  
KingSlamma

WebGL Not Working

Recommended Posts

I was having trouble getting Spells of Genesis to run on Chrome. I was finally able to get it working with these instructions.

 

Enabling WebGL

If your browser supports WebGL, follow these instructions to enable it:

Chrome

First, enable hardware acceleration:

  • Go to chrome://settings
  • Click the + Show advanced settings button
  • In the System section, ensure the Use hardware acceleration when available checkbox is checked (you'll need to relaunch Chrome for any changes to take effect)

Then enable WebGL:

  • Go to chrome://flags
  • Ensure that Disable WebGL is not activated (you'll need to relaunch Chrome for any changes to take effect)

Then inspect the status of WebGL:

  • Go to chrome://gpu
  • Inspect the WebGL item in the Graphics Feature Status list. The status will be one of the following:
    • Hardware accelerated — WebGL is enabled and hardware-accelerated (running on the graphics card).
    • Software only, hardware acceleration unavailable — WebGL is enabled, but running in software. See here for more info: "For software rendering of WebGL, Chrome uses SwiftShader, a software GL rasterizer."
    • Unavailable — WebGL is not available in hardware or software.

If the status is not "Hardware accelerated", then the Problems Detected list (below the the Graphics Feature Status list) may explain why hardware acceleration is unavailable.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to chrome://flags
  • Activate the Override software rendering list setting (you'll need to relaunch Chrome for any changes to take effect)

For more information, see: Chrome Help: WebGL and 3D graphics.

Firefox

First, enable WebGL:

  • Go to about:config
  • Search for webgl.disabled
  • Ensure that its value is false (any changes take effect immediately without relaunching Firefox)

Then inspect the status of WebGL:

  • Go to about:support
  • Inspect the WebGL Renderer row in the Graphics table:
    • If the status contains a graphics card manufacturer, model and driver (eg: "NVIDIA Corporation -- NVIDIA GeForce GT 650M OpenGL Engine"), then WebGL is enabled.
    • If the status is something like "Blocked for your graphics card because of unresolved driver issues" or "Blocked for your graphics driver version", then your graphics card/driver is blacklisted.

If your graphics card/drivers are blacklisted, you can override the blacklist. Warning: this is not recommended! (see blacklists note below). To override the blacklist:

  • Go to about:config
  • Search for webgl.force-enabled
  • Set it to true

(Like Chrome, Firefox has a Use hardware acceleration when available checkbox, in Preferences > Advanced > General > Browsing. However, unlike Chrome, Firefox does not require this checkbox to be checked for WebGL to work.)

Safari

  • Go to Safari's Preferences
  • Select the Advanced tab
  • Ensure that the Show Develop menu in menu bar checkbox is checked
  • In Safari's Develop menu, ensure that Enable WebGL is checked

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...