Jump to content
cdex

Twice I have not received the 5 stamina reward

Recommended Posts

Android 7 --

There have been 2 times so far I've gone watched the google play store ad for 5 stamina bonus and then not received the stamina reward.

On one occurrence I hit to watch the video when there was about 1 second left in my stamina refill timer. I don't know if the fact it was about to increase by 1 caused a glitch with receiving the bonus.

The other time there was nothing out of the ordinary to note. I simply did not receive the bonus.

Share this post


Link to post
Share on other sites

Happened a 3rd time.

This time had 0 stamina, didn't give me reward.

Possible other reason for glitch - whatsapp was running in background and messages were popping up over the game. 

Share this post


Link to post
Share on other sites

Agree, seems to happen on Android and iOS alike, if I remember correctly.

Edit: I think I never had it before launch, but since the app has been updated.

Edited by BenRPG

Share this post


Link to post
Share on other sites

@Yeps @cdex @wachtwoord @BenRPG @KingSlamma 

We are trying to reproduce and analyse in parallel. You could support us, by indicating what steps were done successfully by the system (and where it stops or differs)

a) video ad & stamina popup proposal : “Would you like to watch a video to refill your stamina (5)

b) video start

c) video end, possibility to close the video window/screen (x)

d) closing the video window/screen

e) popup window & message “Got Reward [heart icon] 5 (total stamina already increased)

f) popup window closed, total stamina increased of 5

... even if I suspect the step e) is the one missing

Share this post


Link to post
Share on other sites
4 hours ago, Yeps said:

e) does not happen.

this. a thru d happen. then e-f do not. 

I'd say it works 80% of the time. I tried to provide possibilities why it may not have worked in my original post.

1) stamina was about to recharge based on time refill when I started the video

2) 0 stamina. No reward. (I'm pretty sure I've had it work with 0 stamina on other occasions)

3) Whatsapp was running in background and messages were popping up over the game. 

 

Share this post


Link to post
Share on other sites

Any resolution to this yet?
I have had this occur 6 or 7 times, and I don't play often. I imagine this is happening a lot more to others.

once you close the video there is no message saying you received the stamina and you dont receive any stamina.

@Seb_degraff @Nicolas Sierro

Any compensation?

Share this post


Link to post
Share on other sites
42 minutes ago, cdex said:

This hasn't happened to me in the past few days. I guess just luck of the draw.

There should be no draw. It tells you if you want to watch for the stamina. Used to work better in the beta version.

Share this post


Link to post
Share on other sites

From your feedback, it appears sometime only. I tested with iOS, and it works, We further will try to test it on android. (Other feedback from slack were added as information to the info related this problem)

  • Like 1

Share this post


Link to post
Share on other sites

I also do not get rewarded the stamina around 50% of the time after watching the video and closing it. The last time after closing the video I got an error, something like "Java Exception. Concurrent modification exception."

Share this post


Link to post
Share on other sites

Yea, I get this issue intermittently as well.  I have been trying to isolate the defect but it is inconsistent and so far not repeatable.  These type of bugs are hard to track and fix.  I thought maybe it was fat fingers when leaving the video but the app closes and I am returned to SoG to continue play.  Except when I had zero stamina to start with I don't get to play.  (it is more like the handshake between the video and return to game play fails, the credit does not post)

It might be nice to have an in game way to report when this happens.  At least you might be able to gather or count pings from us when the application fails.  I don't know if there is a log or other information that can be captured when we issue an alert.

Is it possible to give players the ability to turn on debugging or error reporting?  Say we have this happen to us several times over a period of days.  Can you give us a HELP | DEBUG ON switch?  Normally this would be disabled but when we want to try and track an intermittent problem we can enable this which adds a option on the button which allows us to FLAG an issue.  It might give you a real pia if we are all having problems ping ping ping but at least you would feel our pain.  Capture what information you can, part of a log, user info, time of day, previous video, whatever you can gather.  Bind this to the CR form we discussed earlier and allow the user to easily report by clicking a button the most frequent or repetitive errors we are trying to capture, diagnose and repair. 

Just a thought. 

 

Share this post


Link to post
Share on other sites

Okay I have lost my reward for the last four tries. IOS 6+ iPhone. The video plays, the transition screen at the end of the video that allows you to go to the App Store or exit out by selecting the x in the top right corner does not load. The frame loads as a black screen and just sits there. If I use the home button to minimize the app and then return to the app without hard closing it, the play area returns with no rewards given. 

Share this post


Link to post
Share on other sites

We transmitted our problem analysis for this. Today again, as there was another type with Vungle for SimCity /Electronica Arts.
The video never started, you have to bring up the bottom menu, then go to the download section, and here only you have an option to go back to the game Spells of Genesis, without your reward (as the video was not seen).
But this option is not easy to process. Alternative: you close your application and relaunch it (but again without your reward of 5 stamina).

We asked the video ad publisher to control the quality of the video/app and the process to indicate us in SoG app that  the video ad was correctly seen completely.

Till now to solve the problem we EDS deactivated some "video ad providers" that were not working fine (but we cannot deactivate the big one, because only one video/app is not working)

videoAdSoGvungleSimcityNotOk20170527.png

Share this post


Link to post
Share on other sites

Yesterday I was playing with taking video of my battle with "The Purple Dragon."  I wanted to try and post examples of game play for newbies but the file does not even mail because it is over 20 Mb.  I maybe able to trim it to fit but that is not the important thing.

I happened to be recording when the game offered to shell out to the advertisements.  I didn't think anything about it at the time.  When the application returned control to SoG no payment confirmation window was offered.  I thought the handshake went bad.  Hey, if the Presidents of France and the United States can't get a handshake figured out what chance do the test of us have.

It sounds like you are on the scent.  A flag that lets the app know we have successfully watched the advertisement.  I wondered if the x button in some videos was too small.  I wondered if my phone sleep was kicking in and messing up the works.  I am sure once you get them to fix the success flag it will behave as expected. Thanks to the players who take time to report issues, keep it up.

The video worked when the SoG app was running.  Add was missing and stamina payment was missing as well.  It was like it never happened.

If we can help run another diagnostic in the background and send you all log files when it fails.  Let us know.

Share this post


Link to post
Share on other sites

Hi Nicolas,

On the first, I may say, 10 days of game ad rewards worked fine, then it started happening quite frequently, in my case the daily frequency was 33% or 66% as it happened 1/3 or 2/3 times a day, I even remember it happening three times in a row. :(

This kept going on until a week ago (+ or -) so I'd say that in the previous game time I may have easily lost 200+ hearts in rewards. :S

Anyway... it keeps happening, as a proof I attached a video from an Android 6.0.1 device.

I also have its corresponding debug log, but I'm not sure to attach it as I don't know if it may have sensitive information, if you want it don't hesitate telling me and I'll send it to you.

Thanks.

  • Game version number (1.2.0)
  • Device/browser and Operating System (Samsung Galaxy Tab A(2016) 10.1" / 6.0.1)
  • Reproduction steps:
  1. video ad & stamina popup proposal : “Would you like to watch a video to refill your stamina (5)
  2. video start
  3. video end, possibility to close the video window/screen (x)
  4. closing the video
  5. wait for the reward

 

sog1.2.0_AdNoReward.mp4

Edited by Trepanattore
Just to add debug info and to fix some english typos and grammar... I'm not an english native speaker.

Share this post


Link to post
Share on other sites

Hello @Nicolas Sierro

I just wanted to report back on the stamina payout after watching the video clips.

I don't want to jinx it.  The shelling out and back into SoG for Stamina reward seems to be working for me on the android, as of 6/5/17.

I read about the advertisement providers potential issues.  Mentioned in another post.

All the exit buttons in the apps seem to be larger circles (with the x inside) now.  NO little teeny tiny ones that I have seen.

It has been pretty consistent, no drops for the last few days.  Will keep fingers crossed.

Eddy

 

  • Like 1

Share this post


Link to post
Share on other sites

To be on the safe side we have now the Sim City ad blocked for our game, but it was a special case.
For video ad "running" correctly, but the stamina reward is not done (no popup message indicating that the 5 stamina were added), it is further good to indicate us: which ad (e.g. Clash Royale served by Vungle), and the date & time when the problem occurred. 

Share this post


Link to post
Share on other sites

How do I see the add provider? I can easily start writing a list of adds and times where it did not work.

 

On a side note, I have also noticed that sometimes, there is no pop up, so I e.g. use my 6 stamina to play "Prince of the Ice". However, after I played it I see I have 5 or 6 stamina left. So it mast have been added, but without indicating it neither as pop up nor in the stamina bar.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×