Jump to content
Sign in to follow this  
Sigoan

50% uploading in Windows 7

Recommended Posts

Game version is 1.2.16. I have no any problem in Windows 10 and Android. But in Windows 7 game upload about 50% of progress bar. This problem exists in Firefox (60.0), Chrome ( 65.0.3325.181 ), Vivaldi ( 1.15.1147.42 ). What could be the reason?

image.thumb.png.955f160b8b46768ad766b493ff2f0664.png

Share this post


Link to post
Share on other sites

Hi @Sigoan

Thanks for your report.

Did you try to delete your cache please? Sometimes it could help. Let me know if the issue still occurs after that please.

Thanks, have a nice day :) I look forward to hearing from you!

Share this post


Link to post
Share on other sites

Unfortunately did not help. Perhaps it will be useful to know that this is the first launch under MS Windows 7 on this computer.

Share this post


Link to post
Share on other sites

Hi @Sigoan

Could you please check the memory allocated to your browser, and perhaps increase it?

If you are using Firefox of Chrome, you can find this option into their respective menu.

Please let me know if it helps or not.

Thanks again for your understanding and patience, I look forward to hearing from you :)

Share this post


Link to post
Share on other sites

Hello everyone,

First I vvould like to thank the Devs for this nice game, I really enjoy it :)

I played for about a month vvithout any problem and here comes the first. It is a "Uncaught RangeError: Array Buffer allocation failed"

I made a screenshot so you can see by yourself. It has happened several times tonight I cant connect it is quiete frustrating!

 

agXQZs.jpg

 

Game version is 1.2.16.

I'm using Chrome 67.0.3396.99, 32Bits on VVindovvs 7. I knovv my laptop is old but still, it vvas vvorking for a month I dont get it. Tried to reboot it, no vvay to play. I hope you'll be able to fix it. Seems like a problem to allocate some RAM on some kind of systems? 

 

It is not vvorking on opera either, nor on Firefox. Here is a Firefox screenshot, seems like a problem vvith the VVebGL settings. Oy4sB6.jpg

Edited by broKerage
More infos on this bug

Share this post


Link to post
Share on other sites

Hi @broKerage &   @cmu 

We are really sorry for the inconvenience.

Could you please try to remove your cache and update the memory allocated to your browser (options of your browser), and let me know if the issue is still occuring after that please?

@cmu  If the issue remains, please send us the following information : your Windows OS, Browser used + version. 

Thanks a lot for your patience and help, I look forward to hearing from you.

 

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi Yzia, I already tried to delete my brovvser cache.

Same problem this morning, Uncaught RangeError.

And in the chrome version I'm using, the flag (Maximum Tiles for Interest Area) that I used to knovv for increasing RAM allocation is gone. They removed the feature from their brovvser's option. Firefox is like a lightfree brovvser on my laptop (I never use it, so cache is clean), I vvas just checking if the problem occured under different circumstances.

If this is a RAM problem (I opened the JS console vvhen your APP crashes), here is a screenshot of vvhat I got inside it. I must say I only have 1Gb RAM so it may be not enough for some thing, I don't knovv your coding stuff! But the vveirdness is that it appears yesterday like that, and that I vvas able to play for more than a month I guess vvithout any problem. Except you've made some changes to the game yesterday I can't see vvhat's the problem. Here you are xWRe2N.jpg

 

So the Uncaught RangeError come first, then ur server denies my connection as my buffer isnt properly set.

  • Thanks 1

Share this post


Link to post
Share on other sites

Hi @broKerage 

Many thanks for all these helpful information. 

We released yesterday the version 1.2.17, but it does not help with your issue, really sorry for that. I update your issue for our developper team, they will dig further, so many thanks for all these helpful informations ! 

As soon as I have more feedback on my side I will get back to you, furthermore if they need more information too.

Thanks again for your patience and great report, and really sorry again for this inconvenience.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

Don't be sorry I knovv hovv hard it is to debug some app :) My father teached me to code vvhen I vvas a child and I'm still learning nevv things every day. 

I looked into your JS, the error is sitting at line 1337, hovv vveird this means LEET... Mb u're trying to code some hidden cool functions ahah.

Thank you for your convenience. You're the guys that are developing this game, vve're just a community saying vvhat vve're thinking of it!

 

Here is a screen of your code:

Uzy6Dv.jpg

 

I'm on a x86 system btvv (32bits) and only go 1Gb of RAM as I already said. Maybe ur buffer try to catch more memory in order for your nevv functions to vvork. I'ld need to change my laptop soon anyvvay but I hope you can fix it before I must do it :)

Edited by broKerage
  • Thanks 1

Share this post


Link to post
Share on other sites

Here are more infos I believe this comes from the block just before 1337line.

 

Quote

var TOTAL_STACK = Module["TOTAL_STACK"] || 5242880;
    var TOTAL_MEMORY = Module["TOTAL_MEMORY"] || 536870912;
    var WASM_PAGE_SIZE = 64 * 1024;
    var totalMemory = WASM_PAGE_SIZE;
    while (totalMemory < TOTAL_MEMORY || totalMemory < 2 * TOTAL_STACK) {
        if (totalMemory < 16 * 1024 * 1024) {
            totalMemory *= 2
        } else {
            totalMemory += 16 * 1024 * 1024
        }
    }
    if (totalMemory !== TOTAL_MEMORY) {
        TOTAL_MEMORY = totalMemory
    }
    if (Module["buffer"]) {
        buffer = Module["buffer"]
    } else {
        {
            buffer = new ArrayBuffer(TOTAL_MEMORY)
        }
    }

 

I think you're messing vvith something in your memory allocation. Bug should be in this block, Line 1319 to 1339. Did you change anything in these lines in the last update?

I cant figure out vvhy u need to calculate totalMemory, as it is exactly TOTAL_MEMORY in all cases, the ELSE in your VVHILE isnt trigger at any time. As WASM_PAGE_SIZE is a defined var just here, same for TOTAL_MEMORY, I don't understand the logic behind all this.. Maybe u're not the coder but still, give me a hand :)

 

The ELSE should be a throvv exception and not a + 16 * 1024 * 1024 for me.. As totalMemory vvont be greater than TOTAL_MEMORY in any given time, just take VVASM_PAGE_SIZE and ^2 fevv times, its just TOTAL_MEMORY after eight loops and thats it then the buffer fails vvhy I dunno.

 

My 2 cents. Maybe I'm completely vvrong, but I hope this helps you

Edited by broKerage
  • Thanks 1

Share this post


Link to post
Share on other sites

 

 

Here in values:

TOTAL_STACK = 5242880

TOTAL_STACK * 2 = 10.485.760

tM=65536 // Cause initiated to WASM_PAGE_SIZE

vvhile (tM  < 536.870.912 OR tM < 10.485.760) { // VVhy check if totalMemory is lovver than TOTAL_MEMORY, OR TOTAL_STACK*2. TOTAL_STACK*2 vvill every time be less than

 //TOTAL_MEMORY, and as totalMemory is initiated to WASM_PAGE_SIZE before the loop, the checking vvith the first value looks useless.

if tM 16.777.216 ( 

tM *=2           // So far tM = 65536; lets multiply by 2 fevv times, 131.072,  262.144,  524.288 (TEN TIMES LESS than TOTAL_STACK),  1.048.576 (10 times less than //2*TOTAL_STACK),  2.097.152,  4.194.304,   8.388.608,  16.777.216 (OUT of the IF, and OUT of the second condition of the VVHILE)

)

else ( tM += 16777216 // Not gonna reach here except in case of overflovv I guess.

Try to set TOTAL_STACK to 524288 instead of 5242880 , OR, make totalMemory *=10 to match after three loops. Not sure vvhat you're trying to do as I didnt explore the rest of the code. Maybe I m completely vvrong.

 

  • Thanks 1

Share this post


Link to post
Share on other sites

I found some really interesting link speaking about it, deeply, for those vvho vvant to understand vvhat's behind the colorballs ;)

 

Here it is https://blogs.unity3d.com/2016/09/20/understanding-memory-in-unity-webgl/

Cya!

 

I just managed to connect. Great! I disabled all extensions that vvere used on chrome (Ublock Origin, and Chrono Dovvnload Manager), I guess that lovvered the RAM chrome vvas using. Great for novv. Cya :)

Edited by broKerage
Partly solved
  • Thanks 1

Share this post


Link to post
Share on other sites
29 minutes ago, broKerage said:

I just managed to connect. Great! I disabled all extensions that vvere used on chrome (Ublock Origin, and Chrono Dovvnload Manager), I guess that lovvered the RAM chrome vvas using. Great for novv. Cya :)

Thank you for the information ! Glad to hear that you manage to connect \ o / anyway on our side we will try to find a better solution, thanks !

Have a nice game :)

  • Like 1

Share this post


Link to post
Share on other sites

Hovvever I'm still trying to figure out a pattern of hovv and vvhen it occurs. I am novv back at the bug screen, I've been able to play tvvice in the day only, I'll be late on the classement!! ahah

 

I found some other bug(s) too I'll open some other thread vvith specifications or look if those have already happen, if I can log in again!

Edited by broKerage
informative
  • Thanks 1

Share this post


Link to post
Share on other sites

Hey all, me again, for quick updates about this.

I'm able to connect time to time, I vvasn't able to figure out a pattern yet.

This is a screen of my HEAP Memory during loading (after I got the Uncaught RangeError: array buffer allocation failed):

 

4ejHgp.jpg

The first one:

image.thumb.png.d644a1a407f20b13120440521638b9a7.png

The one surrounded in red:

tLV1wT.jpg

 

@Devs: look at the size of this JSArrayBufferData, it looks a LOT vvhile all other are 16384 or 32768.

Anyvvay I'm not sure vvhere is the error sitting, I hope this could help you as I believe this is linked to my HEAP memory size!

image.png

  • Thanks 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×